free html hit counter Cara Remote Mikrotik Jarak Jauh

Cara Remote Mikrotik Jarak Jauh


Dalam implementasi pengelolaan sebuah jaringan, sering kadang kami butuh Cara Remote Mikrotik Jarak Jauh, akses ke sebuah host atau Router dalam jaringan tersebut. Sebagai semisal bila terhadap Router diaktifkan service VPN Server yang diaktifkan supaya Client dari public (internet) sanggup dial ke Router tersebut.

Cara Remote Mikrotik Jarak Jauh paling ringan supaya sebuah perangkat sanggup dibuka dari internet adalah dengan memasang alamat IP Public terhadap alat tersebut. Kendalanya adalah terhadap keadaan khusus IP Public yang terpasang bukan alamat IP static, tetapi sanggup jadi merupakan alamat IP Public Dynamic yang sanggup berubah sewaktu-waktu.

Pada keadaan tersebut terlalu tidak efektif kecuali terhadap sisi VPN Client menunjuk alamat IP Server kala lakukan dial. Sebab kecuali alamat IP terhadap sisi server berubah, pasti link VPN bakal down. Sebagai alternatif, kami sanggup mendaftarkan alamat IP Public kami untuk sanggup diubah jadi nama domain, supaya dari sisi Client sanggup menunjuk nama domain tersebut kala lakukan dial VPN. Tidak cuma VPN, tetapi semisal remote Winbox dan yang lain sanggup termasuk memakai nama domain tersebut.

Remote RouterBoard Mikrotik yang miliki IP Public Dynamic kala ini telah tidak jadi kasus karena merasa Router OS versi 6.14 telah tersedia fitur yang bernama IP Cloud. Dengan fitur ini, kami sanggup mendapatkan nama domain untuk ip public kita, supaya Mikrotik sanggup dibuka memakai alamat nama domain tersebut. Ketika IP Public berubah maka router bakal lakukan update ke Mikrotik.com supaya router selamanya sanggup dibuka dengan nama domain yang sama.

IP Cloud ini sanggup didapatkan secara gratis, cuma wajib mengaktifkan fungsinya saja dalam pengaturan RouterBoard. Format nama domain yang bakal didapatkan adalah [SNRouterBoard].sn.mynetname.net. Cukup panjang sebenarnya dan barangkali tidak ringan diingat. Mengenai IP Cloud sanggup Anda baca lebih dalam ulang terhadap artikel kami yang berjudul Solusi Dynamic IP Public dengan IP Cloud.

Selain IP Cloud yang di sajikan mikrotik, kami termasuk sanggup memakai fasilitas pihak ketiga, bila layaknya www.noip.com . Konfigurasi memakai fasilitas pihak ketiga sebenarnya tidak semudah disaat memakai IP Cloud. Kita wajib lakukan pendaftaran akun dan menyebabkan script update supaya disaat alamat IP Public berubah, Router sanggup meng-update ke server penyedia.

Langkah awal untuk memakai fasilitas noip.com adalah lakukan pendaftaran akun. Pada cara ini selain memilih username akun. Setelah pendaftaran akun kami sanggup memilih nama hostname pilihan kami dan juga menginputkan alamat IP Public router kami yang aktif kala ini. Noip.com menyediakan banyak domain yang sanggup kami pilih.

Jika cara ini telah selesai maka Router Mikrotik telah sanggup kami akses memakai alamat hostname tersebut. Misal disaat remote memakai winbox, terhadap kolom “Connect To” sanggup kami mengisi nama hostname tersebut.

Karena memakai fasilitas pihak ketiga yang tidak miliki fitur update otomatis disaat IP Router berubah, maka terhadap Router wajib ditambahkan mekanisme untuk mengumumkan alamat ip yang aktif ke server noip.com . Untuk keperluan ini kami wajib menambahkan sebuah script layaknya tersebut :

Script update Dynamic DNS untuk NOIP.com

# No-IP automatic Dynamic DNS update

#————— Change Values in this section to match your setup ——————

# No-IP User akun info
:local noipuser “testmikrotik”
:local noippass “testes123”

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost “testmikrotik.ddns.net”

# Change to the name of interface that gets the dynamic IP address
:local inetinterface “ether 1″

#————————————————————————————
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
:local currentIP [/ip address get [find interface=”$inetinterface” disabled=no] address]

# Strip the net mask off the IP address
:for i from=( [:len $currentIP] – 1) to=0 do={
:if ( [:pick $currentIP $i] = “/”) do={
:set currentIP [:pick $currentIP 0 $i]
}
}

:if ($currentIP != $previousIP) do={
:log info “No-IP: Current IP $currentIP is not equal to previous IP, update needed”
:set previousIP $currentIP

# The update URL. Note the “3F” is hex for question mark (?). Required since ? is a special character in commands.
:local url “http://dynupdate.no-ip.com/nic/update3Fmyip=$currentIP”
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info “No-IP: Sending update for $host”
/tool fetch url=($url . “&hostname=$host”) user=$noipuser password=$noippass mode=http dst-path=(“no-ip_ddns_update-” . $host . “.txt”)
:log info “No-IP: Host $host updated on No-IP with IP $currentIP”
}
} else={
:log info “No-IP: Previous IP $previousIP is equal to current IP, nomer update needed”
}
} else={
:log info “No-IP: $inetinterface is not currently running, so therefore will not update.”
}

Ada beberapa parameter yang wajib Anda perhatikan, yaitu:

  • :local noipuser “testmikrotik” (Username untuk login di NOIP.com).
  • :local noippass “testes123” (Password yang digunakan untuk logindi NOIP.com).
  • :local noiphost “testmikrotik.ddns.net” (Hostname yang dibikin terhadap NOIP.com).
  • :local inetinterface “ether 1” (Interface Router yang mengarah ke internet).

Script tersebut sanggup dilaksanakan dengan interval kala khusus dengan memakai scheduler. Misal Router kami set supaya lakukan update setiap 15 menit. Tentu interval ini sanggup dicustom sesuai kebutuhan.

Script update ini terlalu diperlukan supaya kala IP Public yang terpasang di Router berubah kami selamanya sanggup lakukan remote mikrotik memakai Domain dari NOIP.com . Layanan noip.com sebenarnya merupakan fasilitas berbayar tetapi kami diberikan kala trial sepanjang 30 hari. Untuk berlangganan Domain dari NOIP.com sepanjang 1 th. dikenakan biaya sebesar $24.95 up to 25 hostname terhadap kala artikel ini dibuat.


log in

reset password

Back to
log in